Jump to content


Photo

MacDev Clone Issues


  • Please log in to reply
2 replies to this topic

#1 Kking4321

Kking4321

    Member

  • Members
  • PipPip
  • 109 posts
  • Gender:Male
  • Location:Centennial CO

Posted 05 October 2010 - 02:43 PM

I just received my Macdev clone about 2 weeks ago. Leaked right out of the box =/. The
leak is coming out of the bottom of the regulator where you adjust the hpr preassure
there is a o ring in there so i replaced it twice still with no luck its still leaking. I also
contacted macdev two different ways and still no response so if anyone has some ideas
let me know ill give them a try.

Thanks

#2 vzmaniac

vzmaniac

    Sophomore Member

  • Members
  • PipPipPip
  • 745 posts
  • Gender:Male

Posted 05 October 2010 - 06:50 PM

I just received my Macdev clone about 2 weeks ago. Leaked right out of the box =/. The
leak is coming out of the bottom of the regulator where you adjust the hpr preassure
there is a o ring in there so i replaced it twice still with no luck its still leaking. I also
contacted macdev two different ways and still no response so if anyone has some ideas
let me know ill give them a try.

Thanks


try heavily lubing that oring on the brass velocity adjsuter...

then try turning the red reg seat over you may have a bit of dirt dust on it.... finally pull apart your asa assembly and heavily lube it....
DR .P. FAN FOR LIFE YO

#3 True Colours

True Colours

    banned and proud

  • Members
  • PipPipPipPipPipPip
  • 4,288 posts
  • Gender:Male
  • Location:pbnation

Posted 06 December 2010 - 11:41 AM

If its a screw take it out and put teflon tape on it, Then screw it back in.

kinko





2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users