Jump to content


Photo

Tech Support thread


  • Please log in to reply
4 replies to this topic

#1 Teban

Teban

    Vanguard Azteca's Show runner

  • Members
  • PipPipPip
  • 544 posts
  • Gender:Male
  • Location:Monterrey, Mexico

Posted 07 March 2011 - 03:22 PM

Hey guys :)

This is going to be the Tech Support thread for the Creed. Demons will have their own thread.


Ask away!


O-ring Assys chart
O-ring Chart
Quick start guide
Creed velocity adjustment


If you need more assistance, we can work out your issues together on skype.

Add me on skype as esteban.vanguard - Have your creed and questions ready!

Edited by Teban, 07 March 2011 - 03:32 PM.

Want to buy a Creed?

Vanguard distributor: Vanguard Azteca Updates coming soon ;3
Warranty Service Center
Certified Tech
Esteban López. 2.1~

#2 Telman11

Telman11

    Member

  • Members
  • PipPip
  • 137 posts
  • Gender:Male
  • Location:Alberta Canada

Posted 09 April 2011 - 06:42 PM

I don't have skype so I thought I would ask hear. First question is what is my dwell supposed to be set at? And the second question is over the top right corner of my eyes on the screen there is Exclamation mark showing. The gun still shoots fine just not sure why it starting showing up? Thanks Teban.
Feedback Hey laserlips... Your momma was a snowblower!

#3 Teban

Teban

    Vanguard Azteca's Show runner

  • Members
  • PipPipPip
  • 544 posts
  • Gender:Male
  • Location:Monterrey, Mexico

Posted 10 April 2011 - 02:23 AM

The factory setting for the dwell is 12ms. After some cases, lowering it to 11 or even 10.5 is a good idea.

When the exclamation mark shows, most of the time it means it didnt have air when you activated the microswitch (fired the gun). But if you air it up it wont cause any issues. Just restart the marker. If this prevails, let me know!
Want to buy a Creed?

Vanguard distributor: Vanguard Azteca Updates coming soon ;3
Warranty Service Center
Certified Tech
Esteban López. 2.1~

#4 Telman11

Telman11

    Member

  • Members
  • PipPip
  • 137 posts
  • Gender:Male
  • Location:Alberta Canada

Posted 10 April 2011 - 11:19 AM

The factory setting for the dwell is 12ms. After some cases, lowering it to 11 or even 10.5 is a good idea.

When the exclamation mark shows, most of the time it means it didnt have air when you activated the microswitch (fired the gun). But if you air it up it wont cause any issues. Just restart the marker. If this prevails, let me know!


Great, thank you Teban.
Feedback Hey laserlips... Your momma was a snowblower!

#5 TECHDP=)

TECHDP=)

    I'm never online anymore.

  • Players Club
  • PipPipPipPipPipPipPipPip
  • 8,876 posts
  • Gender:Male
  • Location:CALIFORNIA

Posted 18 July 2011 - 06:10 PM

i just got a creed
does it run on LP?

also they said to adjust velocity it was through the LPR? well i did but it started to leak so i backed it out and just did it on the hpr to get at whats now 275fps. 285fps max

#6 sidthecraftycat

sidthecraftycat

    Member

  • Members
  • PipPip
  • 193 posts
  • Gender:Male
  • Location:Chicago IL / Vienna VA

Posted 21 April 2012 - 11:16 AM

...

Edited by sidthecraftycat, 17 May 2012 - 09:07 PM.





2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users