Jump to content


Photo

fixing z2


  • Please log in to reply
9 replies to this topic

#1 empireaxeattack1229

empireaxeattack1229

    Member

  • Members
  • PipPip
  • 66 posts
  • Gender:Male

Posted 29 December 2011 - 02:55 PM

My problem is the white wire came off and I need to know how I can reattach it so the z2 will work again

#2 TheGuy

TheGuy

    I like lamp

  • Members
  • PipPipPipPipPipPipPipPip
  • 13,792 posts
  • Gender:Male
  • Location:Cleveland, OH

Posted 29 December 2011 - 04:32 PM

You arent very specific. Pics help too. Look at the end of the wire where it came out. Is it torn or is there a small plastic piece on the end? If you tore it out then send it to KEE for repair. If theres a small plastic fitting then put it back in place.
Feedback 7/0/0

Rest In Peace

Danijel "Borg" Jagodic


#3 crPaliza

crPaliza

    Senior Member

  • Members
  • PipPipPipPipPip
  • 1,074 posts
  • Gender:Male

Posted 29 December 2011 - 06:28 PM

I'd try consulting the disassembly instructions on the manual first and see if you can fix/adjust the white thingy your talking about. There's also disassembly video on the z2 product web page which is somewhat helpful.

Otherwise,
Calling Empire seems like the next logical step. :-)

Edited by crPaliza, 29 December 2011 - 06:28 PM.


#4 SpaceMan

SpaceMan

    SpaceMan is Unstoppable

  • TechPB Players Club
  • PipPipPipPipPipPip
  • 3,552 posts
  • Gender:Male
  • Location:Lawton, Ok.

Posted 29 December 2011 - 08:33 PM

solder it, i had to also

#5 xincognitopbx

xincognitopbx

    Ripper

  • Members
  • PipPipPipPipPip
  • 1,786 posts
  • Gender:Male
  • Location:Snake One/Two/Three/Four


Posted 29 December 2011 - 09:17 PM

just gotta stick in here why a rotor is more reliable lol. (waits for the onslaught)

Anyways pics would indeed help and how did it come to be this way?

But the Ego 11 is shiny. :(

Dosent the Ego 11 only come in dust colours?

Feedback 2/0/0

#6 TacticlTwinkie

TacticlTwinkie

    *insert witty title*

  • Members
  • PipPipPipPipPipPip
  • 3,974 posts
  • Gender:Male
  • Location:Surf City, USA

Posted 29 December 2011 - 11:14 PM

just gotta stick in here why a rotor is more reliable lol. (waits for the onslaught)

Anyways pics would indeed help and how did it come to be this way?

I think this is user caused, not it falling appart. My z2 hasn't given me a single problem, so I'd recon it's as reliable as a rotor, based on my experiences.

Back to the question. Try to sodder it of you are able to. If you don't have experience with it, call kee and send it off to them for repairs. It sounds like an easy fix for them, so they should be able to turn it around relitavely quickly...I think, don't quote me on that lol.

#7 SpaceMan

SpaceMan

    SpaceMan is Unstoppable

  • TechPB Players Club
  • PipPipPipPipPipPip
  • 3,552 posts
  • Gender:Male
  • Location:Lawton, Ok.

Posted 30 December 2011 - 12:34 AM


just gotta stick in here why a rotor is more reliable lol. (waits for the onslaught)

Anyways pics would indeed help and how did it come to be this way?

I think this is user caused, not it falling appart. My z2 hasn't given me a single problem, so I'd recon it's as reliable as a rotor, based on my experiences.

Back to the question. Try to sodder it of you are able to. If you don't have experience with it, call kee and send it off to them for repairs. It sounds like an easy fix for them, so they should be able to turn it around relitavely quickly...I think, don't quote me on that lol.


same i let my friend use my z2 and he took it apart to clean it and putting the floor back on pulled on the wire. plus a z2 unjams unlike a rotor lol

#8 98Pro

98Pro

    Senior Member

  • Members
  • PipPipPipPipPip
  • 1,874 posts
  • Gender:Male

Posted 30 December 2011 - 12:54 AM

YEah for a rotor to be on par with a Z2 you need a Seed kit which is like $75. So you have almost a $300 loader to come up to par with empires $175 Z2... that's lighter.

#9 Hudson

Hudson

    Member

  • Members
  • PipPip
  • 205 posts
  • Gender:Male
  • Location:Connecticut


Posted 30 December 2011 - 02:09 AM

Solder them together.
-Hudson

#10 xincognitopbx

xincognitopbx

    Ripper

  • Members
  • PipPipPipPipPip
  • 1,786 posts
  • Gender:Male
  • Location:Snake One/Two/Three/Four


Posted 30 December 2011 - 03:20 AM



just gotta stick in here why a rotor is more reliable lol. (waits for the onslaught)

Anyways pics would indeed help and how did it come to be this way?

I think this is user caused, not it falling appart. My z2 hasn't given me a single problem, so I'd recon it's as reliable as a rotor, based on my experiences.

Back to the question. Try to sodder it of you are able to. If you don't have experience with it, call kee and send it off to them for repairs. It sounds like an easy fix for them, so they should be able to turn it around relitavely quickly...I think, don't quote me on that lol.


same i let my friend use my z2 and he took it apart to clean it and putting the floor back on pulled on the wire. plus a z2 unjams unlike a rotor lol


My rotor doesn't jam :P i really haven't had but 2 jams since they came out.. rotors feed more consistent too.

Anyways can you take a pic of this solder project you got going here? i gotta turn it into a techpb meme and put rotor>z2 on it lmfao


But the Ego 11 is shiny. :(

Dosent the Ego 11 only come in dust colours?

Feedback 2/0/0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users