Jump to content


Photo

Crazy Empire Z2 issue!


  • Please log in to reply
No replies to this topic

#1 mrtwo719

mrtwo719

    Knees flexin and arms T-rex'n

  • Members
  • PipPipPip
  • 565 posts
  • Gender:Male
  • Location:Colorado

Posted 01 February 2012 - 10:44 PM

Hey guys, Just got a Z2 in the mail. and I tried putting some reballs through it.. and it does this....




Fucking Odd right? the ball is obviously not jammed. and my fingers have ZERO affect on it until I actually STOP the cone from moving. sooo yea. Witchcraft I say! any ideas?

I have already taken the shells off completely and pulled the drive cone and put everything back together nice and perfect from what I could see..

If I dump a full pod in it it doesn't do shit. just sits there and tries to unjam every now and then.

This is ALL with reballs. I don't have any paint at home so I haven't tried. But I'm worried it doesn't matter.



EDIT: Welllllll Its all good now. I just needed to lube up my balls a bit. no but really. just sticky re-balls. a drop of gun oil and a good shake in a Tupperware. and all is good!! crazy that little bit of friction from ONE reball could cause so much stress!

I also reset the hopper to factory settings.:tup::wub:

Edited by mrtwo719, 01 February 2012 - 11:47 PM.





2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users