Jump to content


Photo

Tippman 98c Regulator


  • Please log in to reply
4 replies to this topic

#1 Dust

Dust

    Newbie On the Block

  • Members
  • PipPipPip
  • 423 posts
  • Gender:Male
  • Location:Mississauga, Ontario, Canada

Posted 20 August 2012 - 02:23 PM

Hey guys.
I was just at a big game and half way through, the screw for my regulator stopped working. My gun shot consistent at 295-300 and no matter where I turned the screw or how much I turned it by, it would not go down. What can I do to fix it?
Thanks.

#2 andrewthewookie

andrewthewookie

    Pull start me and I'm yours ;)

  • Chat Coordinator
  • PipPipPipPipPipPipPipPip
  • 21,615 posts
  • Gender:Female
  • Location:Your bedroom


Posted 20 August 2012 - 04:06 PM

It's possible that you just didn't turn it down enough. I've found that the adjustment level can be weird, in that I've turned adjustment screws on Tippmanns like 9 or 10 times with only a 5 or 10 fps change, then all of a sudden it hits a threshold where the next half turn would change it by 20 fps.

RebelSignaturejedicode-1.jpg
Hybrid SFT • 09 Impulse • HB REV-i • Macroless Mech Ion
Rotor • Grillz • PE 70/45 • Feedback - 23/0/0

Fear is the mind-killer


#3 Dust

Dust

    Newbie On the Block

  • Members
  • PipPipPip
  • 423 posts
  • Gender:Male
  • Location:Mississauga, Ontario, Canada

Posted 20 August 2012 - 04:37 PM

Weird.
Alright, I'll try it.
Thanks.

#4 Myrkul

Myrkul

    Sophomore Member

  • Members
  • PipPipPip
  • 586 posts

Posted 20 August 2012 - 07:39 PM

98s don't have regulators. They have a VA on the power tube though. What you could try doing is installing a RVA. A couple different companies make them, or you could try making one yourself, they aren't too hard. They made a world of difference back when I shot 98s.
"I only drink the blood of my enemies! oh, and occasionally one of those strawberry Slurpee thingies"

#5 VTcadet

VTcadet

    Member

  • Members
  • PipPip
  • 51 posts

Posted 01 November 2012 - 09:13 AM

I would not suggest getting an upgraded power tube only bad things occur, I am a Tippmann gun Tech, Ive seen countless people bring me there marker with valve issues and its always the fact they bought and installed a new power tube. What I need to know is what type of gas you where using. Was is that you just got a co2 tank filled and it was too cold when you wanted to recheck your velocity? If not I would suggest maintenanceing your powertube simply pull on the pin in the back and the assembly will come out clean it up and replace it if that does not work I would order a new ORIGINAL power tube from Tippmann




2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users