Jump to content


Photo

DP G3 velocity +400fps


  • Please log in to reply
5 replies to this topic

#1 q000ball

q000ball

    i Fought The Law, And....I Won

  • Members
  • PipPipPip
  • 401 posts
  • Gender:Male
  • Location:ottawa, ontario

Posted 20 September 2012 - 04:52 PM

Took my G3 (with virtue board and tech-t bolt) out the other day after not using it for a long time. I had lubed it, and everything looked ok. When i went to chrono it, at first it wouldn't fire at all. Then eventually it did, but the FPS was around 325. So i turned it down a bit and it started to leak out the bottom of the reg. I then turned it back up a bit (less than i had turned it down) and the leak stopped. It was then firing at around 450fps. So i know for a fact that the o-ring in the reg was blown, but i don't see how that could ever cause that. Any ideas? Please help me fix this thing so i can get rid of it.

#2 andrewthewookie

andrewthewookie

    Shaaaaaaaaaaaaaaaaarks :(

  • Chat Coordinator
  • PipPipPipPipPipPipPipPip
  • 22,015 posts
  • Gender:Female
  • Location:Your bedroom


Posted 20 September 2012 - 05:05 PM

Check the reg seat. Also, what color is the reg piston? If it's silver, then it's the original piston that had problems when people would bottom out the reg with significant pressure. The updated red reg piston and adjustment screw solved those potential problems.

RebelSignaturejedicode-1.jpg
Hybrid SFT 09 Impulse HB REV-i Macroless Mech Ion
Rotor Grillz PE 70/45 Feedback - 23/0/0

Closer & Angel A1 F/S/T


#3 q000ball

q000ball

    i Fought The Law, And....I Won

  • Members
  • PipPipPip
  • 401 posts
  • Gender:Male
  • Location:ottawa, ontario

Posted 20 September 2012 - 05:41 PM

Check the reg seat. Also, what color is the reg piston? If it's silver, then it's the original piston that had problems when people would bottom out the reg with significant pressure. The updated red reg piston and adjustment screw solved those potential problems.


The oring on the reg seat is the one that is blown. It's one of the new pistons. And it appears that i did a much sloppier job maintaining the reg than i thought i had. So would that be enough to Make the FPS spike that much? As long as i'm able to get out to a field this weekend i plan on seeing if re lubing (properly this time) fixes the problem, and also try out the original bolt just to try and narrow down the problem.

#4 andrewthewookie

andrewthewookie

    Shaaaaaaaaaaaaaaaaarks :(

  • Chat Coordinator
  • PipPipPipPipPipPipPipPip
  • 22,015 posts
  • Gender:Female
  • Location:Your bedroom


Posted 20 September 2012 - 05:43 PM

Maybe. I also forgot to ask about the shim stack. Did you put the shims back in the proper order?

RebelSignaturejedicode-1.jpg
Hybrid SFT 09 Impulse HB REV-i Macroless Mech Ion
Rotor Grillz PE 70/45 Feedback - 23/0/0

Closer & Angel A1 F/S/T


#5 q000ball

q000ball

    i Fought The Law, And....I Won

  • Members
  • PipPipPip
  • 401 posts
  • Gender:Male
  • Location:ottawa, ontario

Posted 20 September 2012 - 06:15 PM

Maybe. I also forgot to ask about the shim stack. Did you put the shims back in the proper order?


I'm 99% sure i did. i have them like this )()()()(

i double checked, and they are in the proper order

Edited by q000ball, 20 September 2012 - 06:32 PM.


#6 andrewthewookie

andrewthewookie

    Shaaaaaaaaaaaaaaaaarks :(

  • Chat Coordinator
  • PipPipPipPipPipPipPipPip
  • 22,015 posts
  • Gender:Female
  • Location:Your bedroom


Posted 20 September 2012 - 08:20 PM

I guess at this point it's just making sure nothing's damaged, and re-lubing at testing it again.

RebelSignaturejedicode-1.jpg
Hybrid SFT 09 Impulse HB REV-i Macroless Mech Ion
Rotor Grillz PE 70/45 Feedback - 23/0/0

Closer & Angel A1 F/S/T





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users