Jump to content


Photo

Autococker Barrel Problem


  • Please log in to reply
3 replies to this topic

#1 mss2iv

mss2iv

    Newbie

  • Members
  • Pip
  • 36 posts
  • Gender:Male
  • Location:sacramento

Posted 01 December 2012 - 10:18 PM

I have a custom autococker pro stock. I always used a WWA freak barrel back on it. But i bought some other barrels online with AUTOCOCKER threads and i tried to put them on but they wouldn't. I tried everything i could think of. I do have a hard time getting the WWA back on because the body is a lil tight and with the oring the barrel back is really tough to turn but it threads on just fine once you get it started, i know this cus without the oring it threads on and off with no trouble.

Please can you help i have never had this problem with barrels with all the other cockers i have owned.

Attached Files


Storm Tooper 57


#2 Myrkul

Myrkul

    Sophomore Member

  • Members
  • PipPipPip
  • 586 posts

Posted 02 December 2012 - 01:56 AM

It is possible that they sent you the wrong barrels. compare the threads, you should be able to see an obvious difference.
"I only drink the blood of my enemies! oh, and occasionally one of those strawberry Slurpee thingies"

#3 mss2iv

mss2iv

    Newbie

  • Members
  • Pip
  • 36 posts
  • Gender:Male
  • Location:sacramento

Posted 02 December 2012 - 05:38 PM

I didn't even think of that. I will check that. From just looking at them they look the same, Ill try aligning the threads.
Storm Tooper 57


#4 Mr. Scott

Mr. Scott

    Sophomore Member

  • Members
  • PipPipPip
  • 454 posts
  • Gender:Male
  • Location:G-spot, Indiana

Posted 01 January 2013 - 04:04 PM

Aluminum threads are easy to mar. If someone ever cross threaded it with a stainless barrel then it can definitely cause problems.
Feedback +22/-0
Yes, the dude with the Ninja Turtles blanket.
Proud to have never sold on PBN




2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users