Jump to content


Photo

Replacing 007 o ring on hyper 3 reg


  • Please log in to reply
2 replies to this topic

#1 TheMason

TheMason

    Newbie

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Location:Charlotte, NC

Posted 29 December 2012 - 07:02 PM

So I was doing some reg maintenance and I took out the existing 007 o ring cuz it looked jacked up... Now I can't get a new one in there.

Anyone have any ideas?

Ps - I have a pm8

#2 dannyboy768

dannyboy768

    TOMA ABBIATI

  • Members
  • PipPipPipPipPip
  • 2,027 posts
  • Gender:Male
  • Location:Orlando, Florida


Posted 06 January 2013 - 09:19 PM

I had this problem, here I copied and pasted my reply on a thread on PBN.



I found a very easy way of installing this o-ring incase any one else is having trouble. Tie a very thin string to the o-ring and drop the end of the string through the hole at the bottom of the stem, then pull the o-ring into the groove and adjust it with a ball end allen key. Then take an exacto knife and cut the string as short as possible. I did this and left a tiny bit of string on the o-ring, built the rest of the reg, aired it up. No problems at all.Still working 5 months later.

Edited by dannyboy768, 06 January 2013 - 09:21 PM.

DIRT CHEAP CF Tanks in Hydro!

http://shop.swapmytank.com/

#3 TheMason

TheMason

    Newbie

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Location:Charlotte, NC

Posted 09 January 2013 - 05:30 AM

I had this problem, here I copied and pasted my reply on a thread on PBN.



I found a very easy way of installing this o-ring incase any one else is having trouble. Tie a very thin string to the o-ring and drop the end of the string through the hole at the bottom of the stem, then pull the o-ring into the groove and adjust it with a ball end allen key. Then take an exacto knife and cut the string as short as possible. I did this and left a tiny bit of string on the o-ring, built the rest of the reg, aired it up. No problems at all.Still working 5 months later.


Thanks - I used a flathead screw driver and it worked




2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users