Jump to content


Photo

SP1 Is leaking Air

air leaking from top grip

  • Please log in to reply
3 replies to this topic

#1 jimmyvondoom

jimmyvondoom

    Newbie

  • Members
  • Pip
  • 7 posts
  • Gender:Male


Posted 27 August 2013 - 01:53 PM

My SP1 is leaking air from the top of the fore grip. I got the gun just over a week ago and i haven't been able to use it, i checked the o rings and they seem fine . I bought it brand new, i need some help

 

 

 

  


Edited by jimmyvondoom, 27 August 2013 - 02:32 PM.


#2 Danny D

Danny D

    Senior Member

  • Members
  • PipPipPipPipPip
  • 2,036 posts
  • Gender:Male
  • Location:Canada

Posted 12 September 2013 - 01:51 PM

Try this:

 

Remove the regulator from the marker.  Unscrew the small set screw on the reg grip, and slide the grip off so your just left with the regulator.  Screw the reg back into the marker.  Feel with your fingers where the air is leaking from.  If its coming out of the holes on the side of the reg, tell me which one.  If its coming from the section which screws into the marker, it is most likely the oring on the top of the reg, which you can replace with a tank o-ring (015/90)



#3 smurfinator22

smurfinator22

    Sophomore Member

  • Members
  • PipPipPip
  • 694 posts
  • Gender:Male
  • Location:Calgary, Canada


Posted 17 September 2013 - 03:26 PM

sometimes because of the stainless steel braided hose's alignment on the reg, you wont be able to screw the reg in enough to get a proper seal. if thats the case then put some teflon tape around the reg threads to seal it off


 


#4 Omarfernando

Omarfernando

    Newbie

  • Members
  • Pip
  • 12 posts
  • Gender:Male
  • Location:Pullman WA

Posted 16 December 2013 - 08:50 PM

I have the same issue but my leak comes out of the barrel so im guessing its not a regulator problem. The gun is also brand new but I bought new o rings for the valve assembly hoping that one of the rings is bad from being stored for so long since sp-1 are fairly old. However doing some reaserch someone on youtube mentioned a HPA and CO2 setting on the blackheart board...I have never heard of that so idk if this guy n youtube is full of crap or maybe thats related to my leak




2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users