Jump to content


Photo

DP fx gun air consumption


  • Please log in to reply
9 replies to this topic

#1 Poochieone

Poochieone

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 28 September 2013 - 08:47 PM

Hey peeps,
I just went out with my dangerous power fusion fx today for the first time.
It took me a little while to tune it up, but once I got it going it worked well. My problem is with how much air I used. I have an empire 48/3000 tank And I had to refill it after every 200 shots. I don't think that's normal, Especially since the gun accuracy starts to go to crp when the pressure dips below 1000. The chrono said I was doing about 280 but would drop slowly with every shot until it got to 269-265.
Any hints at what to look for? Do I need to replace the o-rings?
Any help is appreciated.
Thanks

#2 andrewthewookie

andrewthewookie

    Shaaaaaaaaaaaaaaaaarks :(

  • Chat Coordinator
  • PipPipPipPipPipPipPipPip
  • 21,861 posts
  • Gender:Female
  • Location:Your bedroom


Posted 28 September 2013 - 08:50 PM

Is it a new or used gun? Have you changed any settings like dwell? When was the last time the regs were serviced?


RebelSignaturejedicode-1.jpg
Hybrid SFT • 09 Impulse • HB REV-i • Macroless Mech Ion
Rotor • Grillz • PE 70/45 • Feedback - 23/0/0

Fear is the mind-killer


#3 Poochieone

Poochieone

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 29 September 2013 - 10:47 AM

Hi, it's a used gun. I reset the settings to factory, aside from mode which I used semi automatic on.
I don't know if the dwells were ever serviced, I have not done so.
Any additional thoughts?

#4 crich775

crich775

    Member

  • Members
  • PipPip
  • 218 posts
  • Gender:Female
  • Location:Tacoma, WA

Posted 02 October 2013 - 12:46 AM

check the bolt/rammer return spring.


Rest In Peace Jacob Espindola 1-12-07
OEF Vet 2011-2012, Combat Infantryman Badge Recipient

#5 Jweb

Jweb

    Cardinal

  • Members
  • PipPipPipPipPip
  • 1,182 posts
  • Gender:Male
  • Location:Philly, PA

Posted 03 October 2013 - 12:50 AM

200 balls is way too low. That's literally like a pod and a half per fill. Take out the back cap and make sure everything looks ok o-ring wise. If it didn't come with the manual you can download it online. FX's are usually pretty easy to diagnose + the manual is well put together.


I kind of like neck shots, they give other people the impression that I have a social life.

Meeting Mike and Willie = best paintball day ever.


#6 Poochieone

Poochieone

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 06 October 2013 - 12:07 PM

Hey,
So I took the gun apart to give it thorough cleaning, lube it and make sure all is well.
It all looked good but I'm no expert, especially since putting it back together it had a leak on the pressure regulator area that seemed to come through the breech. Is that an o-ring issue?
Unfortunately I ran out of air so I can't test it again at the moment, after taking the reg apart to ensure all was in order.
Any more input?

#7 Sydarm

Sydarm

    XTC + Ninja + Pinokio

  • TechPB Players Club
  • PipPipPipPipPip
  • 1,977 posts
  • Gender:Male
  • Location:Oviedo, FL

Posted 06 October 2013 - 03:46 PM

My first thought was that you have a leak. Yes, leaking down the breech is an o-ring issue almost assuredly. Check the reg o-rings and service it. Dangerous Power lists the o-ring sizes in their manuals.

#8 andrewthewookie

andrewthewookie

    Shaaaaaaaaaaaaaaaaarks :(

  • Chat Coordinator
  • PipPipPipPipPipPipPipPip
  • 21,861 posts
  • Gender:Female
  • Location:Your bedroom


Posted 06 October 2013 - 07:40 PM

If you're leaking out the breech then the poppet is not sealing or one of the valve o-rings is bad. That is not a reg issue.


Edited by andrewthewookie, 06 October 2013 - 07:40 PM.

RebelSignaturejedicode-1.jpg
Hybrid SFT • 09 Impulse • HB REV-i • Macroless Mech Ion
Rotor • Grillz • PE 70/45 • Feedback - 23/0/0

Fear is the mind-killer


#9 Sydarm

Sydarm

    XTC + Ninja + Pinokio

  • TechPB Players Club
  • PipPipPipPipPip
  • 1,977 posts
  • Gender:Male
  • Location:Oviedo, FL

Posted 06 October 2013 - 08:37 PM

If you're leaking out the breech then the poppet is not sealing or one of the valve o-rings is bad. That is not a reg issue.

^^^ This, I saw DP and was thinking of their g4/g5 spoolie...



#10 Poochieone

Poochieone

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 16 October 2013 - 05:59 PM

Hey guys,
I looked into the o-ring on the regulator and bam, that was it.
Got it gassed up again and it's shooting like a champ !!
thanks for the help!




2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users