Jump to content


Photo

Leaking g4 (big surprise)


  • Please log in to reply
6 replies to this topic

#1 hyoung41

hyoung41

    Member

  • Members
  • PipPip
  • 119 posts

Posted 05 November 2013 - 08:09 PM

I played this weekend and experienced a leak in my G4 and it seemed to be coming from the fitting right below the regulator. anyone know how to fix it or if I would just bring it to the local shop to get it fixed?

 

thanks



#2 Toxin PB

Toxin PB

    California Baller

  • Members
  • PipPipPip
  • 528 posts
  • Gender:Male
  • Location:California

Posted 05 November 2013 - 08:11 PM

Wiggle the macro line , if that doesn't help then get a new fitting

#3 andrewthewookie

andrewthewookie

    Shaaaaaaaaaaaaaaaaarks :(

  • Chat Coordinator
  • PipPipPipPipPipPipPipPip
  • 21,837 posts
  • Gender:Female
  • Location:Your bedroom


Posted 05 November 2013 - 08:12 PM

Is it coming from between the fitting and macroline, or between the fitting and the reg?


RebelSignaturejedicode-1.jpg
Hybrid SFT • 09 Impulse • HB REV-i • Macroless Mech Ion
Rotor • Grillz • PE 70/45 • Feedback - 23/0/0

Fear is the mind-killer


#4 hyoung41

hyoung41

    Member

  • Members
  • PipPip
  • 119 posts

Posted 05 November 2013 - 08:29 PM

It was more the fitting and macro but it definitely not the macro because it swapped it out with an extra one i had. I also can't exactly check it because I don't have a tank at the moment so it would probably be best to just bring it in right?



#5 r45vt

r45vt

    Sophomore Member

  • Members
  • PipPipPip
  • 483 posts
  • Gender:Male

Posted 06 November 2013 - 02:26 AM

If it wasn't leaking from the regulator o-ring just buy a new fitting. Never hurts to buy new macro line either.

Make sure to blue loc-tite the fitting reads so it doesn't leak.

Edited by r45vt, 06 November 2013 - 02:27 AM.


#6 Sydarm

Sydarm

    XTC + Ninja + Pinokio

  • TechPB Players Club
  • PipPipPipPipPip
  • 1,977 posts
  • Gender:Male
  • Location:Oviedo, FL

Posted 06 November 2013 - 02:40 AM

The fittings that came on G4s are total crap. Replace them. I have seen several G4 owners have this issue.


Edited by Sydarm, 06 November 2013 - 02:40 AM.


#7 III Kezia III

III Kezia III

    Lulzjustbeingacat :D

  • Members
  • PipPipPipPip
  • 867 posts
  • Gender:Male

Posted 06 November 2013 - 04:12 AM

you can also use teflon tape instead of blue loctite as well


Lulzjustacat.png





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users