Jump to content


Photo

Vanguard Demon Board won't turn on


  • Please log in to reply
2 replies to this topic

#1 Polojust4paintball

Polojust4paintball

    Newbie

  • Members
  • Pip
  • 38 posts
  • Gender:Male
  • Location:New Jersey

Posted 19 December 2013 - 12:17 AM

Hey guys I need help, I went to go do a standard cleaning and adjust the dwell a little. I was confused because it wasn't turning on and it has never run out of battery before. Tried charging it but would not charge and no charge symbol. Tried reset button and it turned on for two seconds the only thing I saw was that the battery was at lowest it could go. I was hopefully that the battery was just really out of charge but an over night charge of 6 hours showed no change and rest button would not work any more. I'm 98% sure the board is done but if anyone has any suggestions it would be much appreciated. Also if anyone is selling a working board please please help me out.

#2 SOUP

SOUP

    Uber Member

  • Members
  • PipPipPipPipPipPipPipPip
  • 7,708 posts
  • Gender:Male
  • Location:Indiana


Posted 19 December 2013 - 01:46 AM

Replace the battery and see if that does anything. I think the demon comes with a few, each of mine had 2 batteries anyway. 


"Silence is a plus, violence is a must"-Tupac

---Indiana Baller---



#3 Polojust4paintball

Polojust4paintball

    Newbie

  • Members
  • Pip
  • 38 posts
  • Gender:Male
  • Location:New Jersey

Posted 29 December 2013 - 09:58 PM

Mine didn't come with a secondary battery, but I figured out that the screen got paint under it and shorted the screen out.  After I clean it underneath it would come on and turn off.  :(

I guest I need a new board all together.






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users