Jump to content


Photo

Cyclone feed won't latch on to my salvo


  • Please log in to reply
3 replies to this topic

#1 PaintballNewbie99

PaintballNewbie99

    Newbie

  • Members
  • Pip
  • 28 posts
  • Gender:Male
  • Location:Chicago

Posted 26 December 2013 - 02:09 PM

So, I got this cyclone feed for my project salvo so I don't have to shake the thing when I shoot and so when I shoot fast I don't have any ball breaks. So when I'm trying to latch it onto the breach where the paintballs feed into on the marker and it won't click into place. I used the neck that came with the salvo when I first got it and it latched on just fine but when I try to put the cyclone feed neck on it won't lock into place for some reason. Please help! Thanks



#2 bowmasta

bowmasta

    Sophomore Member

  • Members
  • PipPipPip
  • 385 posts

Posted 26 December 2013 - 02:15 PM

Pictures would be great so I could take a look.

 

I can't say I'v ever seen a salvo with a cyclone but if they make them I'm sure it could work.


What?! I'm all out of powdered toast?!

#3 PaintballNewbie99

PaintballNewbie99

    Newbie

  • Members
  • Pip
  • 28 posts
  • Gender:Male
  • Location:Chicago

Posted 26 December 2013 - 04:01 PM

I don't know how to post pictures but i'm willing to try. What are you looking for in the picture? The cyclone on the salvo and the the regular hopper fully latched on?  And I think almost any tippmann 98 custom ( or even some a5  ) upgrade should work on the project salvo. 


Edited by PaintballNewbie99, 26 December 2013 - 04:02 PM.


#4 PaintballNewbie99

PaintballNewbie99

    Newbie

  • Members
  • Pip
  • 28 posts
  • Gender:Male
  • Location:Chicago

Posted 26 December 2013 - 06:24 PM

Nvm I found out what the problem was, I know no one is gonna read this or care about this but i'm going to post this anyway. So for some reason when I used the regular neck the little tab that comes up and latches to the neck to lock it in place it worked just fine, but because of the little differences from the cyclone feed and the regular neck, the cyclone feed would automatically push that tab down making it damn near impossible to put the cyclone feed in place, but what i noticed was if I pushed it forward when I put it on the tab would go up but blocking the arm that latched it on so i figured if I pushed it forward and then quickly put it into place before the tab could go up then it should lock it into place. Sooo yeah jamming it into place worked. 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users