Jump to content


Photo

Azodin Blitz shooting soft


  • Please log in to reply
6 replies to this topic

#1 ChookiPooki

ChookiPooki

    Newbie

  • Members
  • Pip
  • 11 posts
  • Gender:Male
  • Location:Bakersfield, CA

Posted 28 January 2014 - 08:43 PM

i have this azodin blitz that I got from my friend for free cuz it wont shoot correctly. I aired it up and shot it a few times, and the balls barely leave the barrel before they fall to the ground. I have a sufficient air supply and the reg is fine. it does the same thing with any reg that is on it. the detents are fine and the eyes work, but it just shoots EXTREMELY soft. it doesn't leak or anything and I took it apart and nothing seems to be broken or missing. I cant send it to azodin because I don't have the warranty anymore. its only been used like 2 or 3 times. I have adjusted the velocity on both the reg and the gun to all sorts of levels and it still shoots exactly the same. I just cant figure out the problem. any help would be appreciated.



#2 Poopfairy35

Poopfairy35

    Providing useless insights here since 2013

  • Members
  • PipPipPip
  • 432 posts
  • Gender:Male
  • Location:Potville, USA


Posted 28 January 2014 - 10:23 PM

Can you post a video? There are a number of things that could be going wrong here. Also, there will be no problems with sending it in to Azodin without a warranty card.
& it honestly sounds like you're low on air.
I am a raccoon.

#3 ChookiPooki

ChookiPooki

    Newbie

  • Members
  • Pip
  • 11 posts
  • Gender:Male
  • Location:Bakersfield, CA

Posted 28 January 2014 - 10:48 PM

sorry but I cant post a video and I don't want to send it in because I don't want to pay and arm and a leg for them to fix it. all of the tanks I tried had 2500+ psi in them. I have even tried it with a topped off 68/4500

#4 P.A.N

P.A.N

    Techpb to the front!

  • Members
  • PipPip
  • 296 posts
  • Gender:Male


Posted 29 January 2014 - 08:41 PM

Try turning the screw in the back of the gun clockwise or in. It is the velocity adjustment screw. It is located in the rear of the marker under the bolt. you unscrew the whole assembly to get to the striker o ring. 


Edited by P.A.N, 29 January 2014 - 08:49 PM.


#5 P.A.N

P.A.N

    Techpb to the front!

  • Members
  • PipPip
  • 296 posts
  • Gender:Male


Posted 29 January 2014 - 08:50 PM

If you want to try to get it to shoot as hard as you can, back the reg all the way out and tighten the velocity adjustment screw all the way in



#6 ChookiPooki

ChookiPooki

    Newbie

  • Members
  • Pip
  • 11 posts
  • Gender:Male
  • Location:Bakersfield, CA

Posted 08 February 2014 - 04:42 PM

I have noticed that when I shot it, some air blows out the back of the bolt. I don't know if that might be the problem or if azodins just do that. that's the only thing I could think of at this point. I have tried almost everything including backing out the reg and turning the adjustment screw in.



#7 Poopfairy35

Poopfairy35

    Providing useless insights here since 2013

  • Members
  • PipPipPip
  • 432 posts
  • Gender:Male
  • Location:Potville, USA


Posted 09 February 2014 - 12:56 PM

I'm telling you man, send it in to Azodin. All you have to pay for is shipping & a $20 repair fee AT MOST. They're more likely to fix it for free.
I am a raccoon.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users