Jump to content


Photo

Problems with creed, Please help


  • Please log in to reply
7 replies to this topic

#1 bL^

bL^

    Sophomore Member

  • Members
  • PipPipPip
  • 501 posts
  • Gender:Male
  • Location:Ontario, Canada

Posted 28 September 2009 - 06:13 AM

So I bought a new vanguard creed, and I'm having trouble with it.
1st, When I charge it for the first time the usb door ripped off, not much I can do about that.
2nd, I air it up before the game and left the air on and I've got a slow leak of about 500psi per 30mins or so, any idea where that can be coming from?
3rd, Efficiency is horrible, 3 pods on 68/3k :S , once again any ideas?
4th, The LPR wiggles when its not aired up, I'm assuming this isn't normal, also when the gun starts to get low on air and I fire it the LPR moves around.

Other than all that it shoots like a dream when its on a full tank of air.... all suggestions welcome, its kinda frustrating to spend that kinda money on a gun and it performs like that.

#2 Paintball666Metal

Paintball666Metal

    Sophomore Member

  • Members
  • PipPipPip
  • 698 posts
  • Gender:Male
  • Location:Canada

Posted 02 October 2009 - 03:58 AM

Hmm...something is up there, sounds like it could be leaking out of the lpr if its loose? #'s 2-4 sound like they could be related.

I would suggest emailing sales@vanguardpaintball.com , her name is Emma, and copy and paste those things in an email, and then ship it to Vanguard when you have a period of time when you arn't playing for a while, and they'll fix it up for you for free, all that is under warranty.

Keep me updated, I want to make sure this get's sorted out ASAP.
www.factorypaintballsupplies.com - Your source for the Vanguard Creed marker.


#3 Tucan9999

Tucan9999

    You never go ass to mouth!

  • Members
  • PipPipPipPipPipPipPip
  • 5,576 posts
  • Gender:Male
  • Location:Delaware

Posted 14 October 2009 - 09:32 PM

I've got the LPR problem and my HPR wiggles too.
TIMMY MILITIA Cause its the only club with MUTHA FUCKIN SNAKES
Mod App

#4 Nobben #44

Nobben #44

    Life's too short to drive boring cars

  • Members
  • PipPipPipPipPipPipPipPip
  • 11,465 posts
  • Gender:Male
  • Location:Land of Fresh Fish


Posted 15 October 2009 - 08:53 AM

mine is abit inconsistense(?) right now... whats the stock dwell settings?

#5 Tucan9999

Tucan9999

    You never go ass to mouth!

  • Members
  • PipPipPipPipPipPipPip
  • 5,576 posts
  • Gender:Male
  • Location:Delaware

Posted 15 October 2009 - 03:08 PM

Mine is at 12.
TIMMY MILITIA Cause its the only club with MUTHA FUCKIN SNAKES
Mod App

#6 Paintball666Metal

Paintball666Metal

    Sophomore Member

  • Members
  • PipPipPip
  • 698 posts
  • Gender:Male
  • Location:Canada

Posted 16 October 2009 - 01:27 AM

Mine is at 12, I emailed Vanguard to make sure, and yes, 12 is stock dwell. :)
www.factorypaintballsupplies.com - Your source for the Vanguard Creed marker.


#7 deathtoyou

deathtoyou

    Member

  • Members
  • PipPip
  • 112 posts
  • Gender:Male
  • Location:in yo momma

Posted 09 March 2010 - 01:30 PM

first off you should talk to eric R from CS he will hook you up, http://www.pbnation....d.php?t=3326577 that could be a good help as well. if you need erics contact info his username is SHOOTNPOO on PBN. lmk if there is anything else i can do to help you get this beast sorted out.

Did you try to tighten the screw between the body and HPR? what do you mean the LPR is loose? is the pin installed alright?
MINOT MILITIA
siamese camo geo death twin #1

you know who I is

#8 inclininggerm

inclininggerm

    disease...eminent

  • Members
  • PipPipPipPipPip
  • 1,456 posts
  • Gender:Male
  • Location:Austin, Tx

Posted 09 March 2010 - 03:54 PM

first off you should talk to eric R from CS he will hook you up, http://www.pbnation....d.php?t=3326577 that could be a good help as well. if you need erics contact info his username is SHOOTNPOO on PBN. lmk if there is anything else i can do to help you get this beast sorted out.

Did you try to tighten the screw between the body and HPR? what do you mean the LPR is loose? is the pin installed alright?

Posted Image




2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users