Jump to content


ShotS

Member Since 29 Sep 2011
Offline Last Active Feb 03 2012 01:41 PM
*----

Topics I've Started

Dye Rotor V3 $120 shipped!

02 May 2012 - 08:40 PM

BASICALLY GONE!!! JUST NEED TO SHIP IT OUT. MODS PLEASE DO NOT DELETE TILL I SHIP. THANKS!!!




Item: Dye rotor
Condition: 8/10
Known Problems: none, except cosmeticly one of the windows is SLIGHTLY chipped. does not affect performance in the slightest bit and it still holds on very tight. pictures show it.
Asking Price: 120 Shipped!!!!!!!!!!!!
Shipping Options: Whatever you want
Trades of interest: unfortunately none, need money for paintball
Location of item: Maryland
What is Included: Rotor, unfilled warrenty card, box, and manual!!!


Posted Image

Uploaded with ImageShack.us



Posted Image

Uploaded with ImageShack.us



Posted Image

Uploaded with ImageShack.us



Posted Image

Uploaded with ImageShack.us



Posted Image

Uploaded with ImageShack.us

Empire Axe leaking and bolt lock

15 April 2012 - 07:08 PM

title says it all. i have fresh batteries in it, pressures are set right, settings are set right, however when i air it up, it makes a pop then leaks out the barrel and the bolt goes forward then locks itself in place which causes the leak, so guys i really need your help.and everything is lubedis it just a matter of changing orings? and if so, which ones?


problem solved. cookybiscuit saved the day

WTB EMPIRE AXE NANO FEEDNECK

26 March 2012 - 02:51 PM

title and subtitle says it all, i will pay good money for it. OFFER!

WTB DM7 bring me your DM7

09 February 2012 - 11:57 AM

title says it all. also we can do local deal or deal through paypal . just lmk and hmu with offers

G6R shooting like sh*t

06 February 2012 - 10:55 PM

alright, so as you can see in my sig i have a g6r, yes it is for sale; HOWEVER, i havnt bumped the thread in a while because like the title says my g6r is shooing awful.

i dont have a pressure tester, and i know that might help somewhat, but i mean with a full tank all its doing is little teeny tiny puffs of air and i sit there and play with both the lpr and hpr for many minutes and i still keep getting tiny puffs as if it was on training mode(if there was one). All the orings are good, completely taken apart and lubed with dow 55-the sugested lube- i believe the board settings are stock, or pretty close to it, gun looks great, its clean and everything, the spring where the popit goes is in the right place and direction.
Also, the trigger spring keeps coming off and makes the gun go full auto and its really anoying.



I dont understand it, because back in december it was shooting like a dream and would get almost a case off of one fill, but then the next day it was only getting 3 pods off of one fill, chrono'd at 280(field limit-vaca down in GA at classic, im at paps now MD) but it shot quieter and smoother. i just really dont get it, and its really upsetting. also its been chopping alot recently, could be because i only have one detent in it dunno.



so yea thats pretty much it. and i do want to buy a pressure tester, i just dont see spending $50 on one, if anyone knows of one used, lmk. Also, yes i do plan on buying a new pair of detents.



-edit- and a pillow bolt as well